XMI read fails on ok file

Please use this forum to signal bugs.
Merci d'utiliser ce forum pour signaler des bugs.

XMI read fails on ok file

Postby thomas.beale » Wed 5 Mar 2014 16:37

BOUML 6.4.6 on Windows 7

I try to do an XMI import but it fails with the message

~~~~~~~~~~~~~~~~
Xmi 2.x import release 5.0.2
import C:/project/CIMI/RM/CIMI RM v1.0.1-dstu - Copy.xmi
error in C:/project/CIMI/RM/CIMI RM v1.0.1-dstu - Copy.xmi line 1 : unexpected character 'ÿ'
~~~~~~~~~~~~~~~~~

XMI attached.


- thomas
thomas.beale
 
Posts: 45
Joined: Wed 21 Mar 2012 20:37

Re: XMI read fails on ok file

Postby Bruno Pagès » Wed 5 Mar 2014 19:52

Hi,

There is no attached file

Bruno
ImageAuthor of Bouml
Bruno Pagès
 
Posts: 449
Joined: Mon 20 Feb 2012 08:23
Location: France

Re: XMI read fails on ok file

Postby thomas.beale » Wed 5 Mar 2014 20:12

Attachment added again ... aha - extension xmi not allowed... nor is .txt.... ok finally... managed to add a .7z file.
Attachments
CIMI RM v1.0.1-dstu.xmi.7z
(17.42 KiB) Downloaded 558 times
thomas.beale
 
Posts: 45
Joined: Wed 21 Mar 2012 20:37

Re: XMI read fails on ok file

Postby Bruno Pagès » Wed 5 Mar 2014 20:22

You are right, I added extensions c, cpp, csv, diz, h, hpp, ini, js, log, txt, xmi and xml

Your xmi file is in UTF-16, I don't manage it

The attached file is the same except the encoding and I put some enumeration literal in comment because their name are illegal in bouml
Attachments
cimi.xmi
(99.98 KiB) Downloaded 576 times
ImageAuthor of Bouml
Bruno Pagès
 
Posts: 449
Joined: Mon 20 Feb 2012 08:23
Location: France

Re: XMI read fails on ok file

Postby thomas.beale » Thu 6 Mar 2014 08:22

Thanks, that works. I don't know why EA uses UTF-16, UTF-16 is an abomination. Although Windows uses it as well....

What file converter did you use?
thomas.beale
 
Posts: 45
Joined: Wed 21 Mar 2012 20:37

Re: XMI read fails on ok file

Postby Bruno Pagès » Thu 6 Mar 2014 09:59

I was under Linux and I finally convert the file using the editor gedit, of course I had to change by hand the first line to replace utf-16 by utf-8, then after doing the xmi2 import I noticed the problem with the enumeration literal names.
ImageAuthor of Bouml
Bruno Pagès
 
Posts: 449
Joined: Mon 20 Feb 2012 08:23
Location: France

Re: XMI read fails on ok file

Postby thomas.beale » Thu 6 Mar 2014 23:59

Will you make BOUML support UTF-16? I'm asking because I suspect Enterprise Architect's default XMI export format may be that (at least on Windows), and EA is a very common UML tool...

- thomas
thomas.beale
 
Posts: 45
Joined: Wed 21 Mar 2012 20:37

Re: XMI read fails on ok file

Postby Bruno Pagès » Sun 9 Mar 2014 11:04

Thomas,

I introduced a partial management of UTF16, in advance you can get http://www.bouml.fr/files/ixmi2.exe (you need first to install the last release of Bouml, else you will have a compatibility problem)
ImageAuthor of Bouml
Bruno Pagès
 
Posts: 449
Joined: Mon 20 Feb 2012 08:23
Location: France


Return to Bug reports / Rapports de bugs

Who is online

Users browsing this forum: No registered users and 1 guest

cron