You don't have a licence message

Please use this forum to signal bugs.
Merci d'utiliser ce forum pour signaler des bugs.

You don't have a licence message

Postby adi » Tue 9 Sep 2014 17:13

I need some help, looks like there is a bug with the license recognition. If I start the BOUML program directly everything works just fine. If I try to open the *.prj project file (it is associated for opening with bouml.exe) I get a message "You don't have a licence". It is this a normal behavior or I need some special settings?
adi
 
Posts: 8
Joined: Tue 9 Sep 2014 16:58

Re: You don't have a licence message

Postby adi » Tue 9 Sep 2014 17:38

For now, a quick work around will be to create a "bouml.bat" file in the same directory where bouml is installed with this content:
~
cd D:\work\programs\Bouml
D:\work\programs\Bouml\bouml.exe %~f1
~
After that the *.prj file must be associated for opening with "bouml.bat", not "bouml.exe".
Just replace the installation path with your own. I hope this detail will be fixed in the next bouml release.
adi
 
Posts: 8
Joined: Tue 9 Sep 2014 16:58

Re: You don't have a licence message

Postby Bruno Pagès » Tue 9 Sep 2014 17:42

Bouml get the licence file in the current directory.

When you start Bouml through its icon/shortcut the current directory is set to the directory where you installed Bouml, so Bouml find the licence file.

When you associate the extension prj with Bouml and you double click on a prj file, the current directory is not set to the directory where you installed Bouml, so Bouml doesn't find the licence file and say you don't have. To be able to use extension association you have to create a bat file going in the directory where Bouml is installed before to launch bouml with the parameter, and to associate the prj extension with this bat file. Supposing Bouml is installed under C:\Program Files (x86)\Bouml the bat file contains :
Code: Select all
cd "C:\Program Files (x86)\Bouml"
bouml %1
ImageAuthor of Bouml
Bruno Pagès
 
Posts: 449
Joined: Mon 20 Feb 2012 08:23
Location: France

Re: You don't have a licence message

Postby Bruno Pagès » Tue 9 Sep 2014 17:43

ok you found the way by yourself
ImageAuthor of Bouml
Bruno Pagès
 
Posts: 449
Joined: Mon 20 Feb 2012 08:23
Location: France

Re: You don't have a licence message

Postby Bruno Pagès » Sun 21 Sep 2014 16:59

From the release 6.6.3 I just delivered the bat file is not necessary, Bouml by itself set the current directory to the executable directory, you can link directly bouml.exe to the extension prj
ImageAuthor of Bouml
Bruno Pagès
 
Posts: 449
Joined: Mon 20 Feb 2012 08:23
Location: France


Return to Bug reports / Rapports de bugs

Who is online

Users browsing this forum: No registered users and 0 guests