Problem sharing project between platforms

Please use this forum to signal bugs.
Merci d'utiliser ce forum pour signaler des bugs.

Problem sharing project between platforms

Postby lgb » Mon 7 Dec 2020 21:53

We are a group that are planning to use BoUML in a project. The problem is that we use different platforms, MacOS, Windows and Linux.
It is not possible to open a project on MacOS after it has been changed on Windows.
MacOS uses version 7.9 and format 222, Windows uses version 7.10 and format 223.
One solution would be to use version 7.9 on all computers, but only the latest version is available on the download page, so that is not possible.
lgb
 
Posts: 2
Joined: Mon 7 Dec 2020 16:53

Re: Problem sharing project between platforms

Postby Bruno Pagès » Mon 7 Dec 2020 23:19

A new version is able to load a project made/modified by any older version, but the reverse is of course false.
You need to use the same version of BoUML on all platforms.

The Mac I used to make the version for MacOS is dead, and it is mandatory to have a Mac to use Macos, this is why I stopped to produce the version for Mac. Mac are very expensive and at the same time have defaults limiting their life (frankly speaking planned obsolescence), I do not plan to buy a new one, just compare them with Raspberry Pi at few $ !

Note also I use QT4 which start to not be available on some Linux platform and I do not plan to move to QT5 then 6 etc, the days of BoUML are then numbered, all has a end, is is probably better for you to use an other tool, sorry.

Kind regards
Bruno Pagès
ImageAuthor of Bouml
Bruno Pagès
 
Posts: 689
Joined: Mon 20 Feb 2012 09:23
Location: France

Re: Problem sharing project between platforms

Postby lgb » Tue 8 Dec 2020 08:03

One solution would be to add links on the historic page to previous versions, so it would be possible to use the same version on all platforms.
lgb
 
Posts: 2
Joined: Mon 7 Dec 2020 16:53

Re: Problem sharing project between platforms

Postby Bruno Pagès » Tue 8 Dec 2020 13:15

I made thousand packages since 2005 and a version uses typically 250Mo for its packages, I cannot save all

Anyway the 7.9.1 is still available (the 7.9.1 is fully compatible with the 7.9 but fixes problems) :
  • For Windows : https://www.bouml.fr/files/Bouml_7.9.1_setup.exe
  • For Debian/Ubuntu : replace "apt" by "apt_7.9.1" when configuring my repository
  • For other Linux the name of the package contains the version of BoUML, so look at the path for the 7.10 in the download page and replace "7.10" by "7.9.1" in the path
[/list]

Kind regards
Bruno Pagès
ImageAuthor of Bouml
Bruno Pagès
 
Posts: 689
Joined: Mon 20 Feb 2012 09:23
Location: France


Return to Bug reports / Rapports de bugs

Who is online

Users browsing this forum: No registered users and 2 guests

cron