Page 1 of 1

The release 7.11 is a final version.

PostPosted: Thu 26 Aug 2021 09:00
by Bruno Pag├Ęs
BOUML uses QT4 + QT3 support but QT4 is now removed from several Linux distributions and I will not move to QT5 (nor 6 etc).
I distributed the first release in 2005, it is time to stop.

Re: The release 7.11 is a final version.

PostPosted: Thu 2 Sep 2021 14:06
by petr.fedorov
Hi Bruno,
It seems BoUML works pretty well on Debian 11 from Docker container (built on top of Debian 10). I expect that there Docker will have official Debian 10 container for the next 10 years (as oldoldstable), so BoUML may stay with Qt4 + Qt3 for 10(!) more years!

Then I have a strong desire and enough time to help with migration to Qt5, 6 etc. 10 years should be enough for that I suppose. For sure I'll be able to help with testing (some time ago I tested and improved StateMachine generator).

If nevertheless you don't want to reconsider your decision to stop, please think about opening the source code. BoUML is great and does not deserve to be buried alive.